Linuxdoc Linux Questions
Click here to ask our community of linux experts!
Custom Search

7. Installing from scratch

ACPI is constantly being revised. It is available in later versions of the 2.4.x series kernel (2.4.22 and higher), and all 2.6.x series kernels. If you would like to use a kernel before 2.4.22, you will need to patch your kernel source to add ACPI functionality. If at all possible you should use the latest stable version of the kernel. Patches are available from acpi.sourceforge.net.

Red Hat Fedora Core 2 now ships with ACPI enabled by default! This is big progress for the ACPI development team. Congratulations to everyone.

Note

Even the latest kernel will sometimes have minor bug fixes available as a patch. You should check the ACPI4Linux web site to see if there are any patches available.

You need to get the patch that exactly matches the version of the kernel that you are running. Since this is the "install from scratch" section I will assume you know exactly which kernel you will be installing.

7.1. Choosing a kernel

This document was originally written for the 2.4.20 kernel and has been updated since to include information about the 2.6.x series kernels. At the time of this update the 2.6.x series kernels are proving easy for some and harder for others. (I personally cannot properly power down my computer with the 2.6.5 kernel.)

If you can, I would recommend waiting to upgrade your kernel to the 2.6.x series until more bugs are ironed out. There are a lot of changes in the 2.6.x series kernel. When I upgraded to 2.6.5 to update this document I ran into problems with my wireless connection, my nvidia graphics card, and with ACPI. Your mileage may vary. I personally had good success with the 2.4.20 with the latest patch and the 2.4.22 kernel with no patch. A Google through your distribution's mailing list, and the acpi-devel mailing list should help you to pick the right kernel.

Note

This document uses the 2.4.20 kernel as an example for 2.4.x series kernels. Substitute your own kernel version as appropriate.

Regardless of which kernel you choose, if it is a kernel that requires patching, it is important to use the latest version of the ACPI patch. Some distributions have already patched their kernels. This is the case for Debian, and may be the case for others. For more information on the patches that have been applied to the Debian kernel source package scan through: /usr/src/kernel-source-<version>/README.Debian. If you are not using Debian you will probably still be able to find an equivalent file for your distribution.

A user on acpi-support confirmed that I shouldn't need any of the additional patches that have been applied to the kernel to run my laptop. If you are running a production-level server and/or are serving web pages to the internet, you should really apply any additional security patches.

Warning

If a kernel has had other patches applied to it, you may have problems applying the ACPI patch. Of course, an ACPI patch should not be applied to a kernel that is already patched for ACPI. As long as there has not been an ACPI patch applied to the kernel it should be possible to apply one now. Depending on the patches applied, you may need to modify some of the Makefiles for your patch to be successful. This is beyond my current grasp of reality so it is not covered in this document.

7.1.1. Debian-ized pre-patched kernel

If you would prefer to use a Debian-ized kernel instead of a fresh one, maxx has provided a pre-patched kernel-source package with the latest patch for the 2.4.20 kernel. This would be instead of downloading a fresh (non-patched) kernel from www.kernel.org. He sent me an email with the following details:

 

I took the kernel-source 2.4.20-8 from unstable, removed the ACPI changes [i.e. the old patch] and applied acpi-20021212-2.4.20.diff.gz from acpi.sf.net since the vanilla 2.4.20 HAS several security leaks (ptrace, hash table, ...).

You can find the package at http://people.debian.org/~maxx/kernel-source-2.4.20/ (I didn't upload the .orig.tar.gz since you can get it from any debian mirror and the .deb is already big enough)

 
--maxx  
Warning

I have not tested these packages. You may or may not have any luck with them. Please don't email me asking about them, ask maxx instead.