Linuxdoc Linux Questions
Click here to ask our community of linux experts!
Custom Search
Next Previous Contents

4. How to install ALSA sound drivers

4.1 What you need

The great thing is: you don't need a supported sound card anymore, as ALSA now has a dummy driver that does nothing! (No, it really does nothing, but some programs will work now that they believe there is a sound card available).

If you have a PnP card, you will also need:

The INSTALL text in the driver directory suggests that for some cards, PnP support is native. I also received a suggestion from Jaroslav about this. When I get further information about this topic I will add it to this mini-HOWTO.

Please note that you should not have any sound drivers active when you want to use the ALSA drivers. If you have a kernel with sound drivers compiled in, you'll need a kernel recompilation. If you have the old "sound.o" module active, you need to deactivate it. If you use kerneld, this probably means deleting sound.o from the /lib/modules/<kernel_version>/misc directory. Newer RedHat systems have a different sound approach, with several sound modules active. You need to deactivate them all.

The 2.2 series kernel has a new approach to sound. You should include sound support here ! Yep, that's right: you add sound support to the kernel, but do not include any sound card. Then compile and install the kernel and after that, compile the ALSA-drivers.

4.2 Getting the drivers

The ALSA drivers are available from ftp://ftp.alsa-project.org/pub/ and there are mirrors at

For a fully functional ALSA-installation, you will need the driver, the libs and the utilities; e.g if you chose the A2000 mirror you would get ftp://linux.a2000.nl/alsa/driver/alsa-driver-0.4.1e.tar.gz, ftp://linux.a2000.nl/alsa/lib/alsa-lib-0.4.1d.tar.gz and ftp://linux.a2000.nl/alsa/utils/alsa-utils-0.4.1.tar.gz

4.3 ALSA versions

The ALSA drivers have come a long way. Development started during the 2.0 version kernel, then the 2.2 series showed up (with their own sound kernel).

As the 0.4 versions work perfectly for me, I think it is safe to use 0.4.1e (or newer, if you want). If you have a 2.0.x kernel, you will definately not want to use 0.3.0 or later. Instead, use alsa-driver-0.3.0-pre4, alsa-lib-0.3.0-pre4 and alsa-utils-0.3.0-pre3.

The older versions, 0.2.0-pre10p3 and older do work under 2.0.x, but I cannot get them to work under 2.2.x (probably due to the lack of interfacing with the soundcore module of the kernel).

4.4 Extracting

You extract the drivers by some reasonable command, like the all-time tar -zxf <file>. Most likely you would do that in the /usr/src directory, so you need root priviliges for this. Type ``su'' and then the root password to become root. But please note: it is unwise to use your system as the ``root'' user if it is not necessary. So:

cd /usr/src

tar -zxf ~/alsa-driver-0.4.1e.tar.gz

tar -zxf ~/alsa-lib-0.4.1d.tar.gz

tar -zxf ~/alsa-utils-0.4.1.tar.gz

Also working and more fun: find ~ -name alsa* -exec tar -zxf {} \; (Don't try this at home kids, it's just an example). Note that when downloading the drivers with Netscape, you may accidentally get unpacked drivers with a ".tgz" extension. If tar complains about the file format, you may get better results by leaving off the "z" in the tar options.

4.5 Compiling

You need the drivers before you can compile and use the libs. You need the libs before you can compile or use the utils. So let's begin:

cd alsa-driver-0.4.1e

(and for those not so experienced: try typing a <tab> (the "tab"-key) after "alsa-d". That's called command line completion.)
./configure

If you want to use the built-in PnP interfacing, you should use
./configure --with-isapnp=yes

make

Now you need to be 'root' to install the stuff (you probably were "root" already)
make install

If this tells you that something like ``version.h'' cannot be found, then you probably do not have a proper kernel source tree. You need a couple of files of your kernel source to be able to compile the ALSA-drivers. Unpack your favorite linux-2.x.y.tar.gz in /usr/src, and issue a make menuconfig. (Actually, make symlinks may be enough). Now compile the libraries:
cd ../alsa-lib-0.4.1d

./configure

make

make install

OK, you're getting it, the utilities:
cd ../alsa-utils-0.4.1

./configure

make

make install

Note: you can leave out the "make install" for the utilities at first. You could even leave out the whole library-making and utility-making, just to check if the driver works.

4.6 Preparing the devices

There is a script in the driver-directory that will install the ALSA-sound-devices in your /dev directory. Type

./snddevices

from the driver-directory. There should be a /dev/snd subdirectory now (test if it is there. If you are not familiar with even the "ls" command, please consider reading other HOWTO's first. You should have some basic Linux knowledge to install these drivers).

Now you're ready to insert the driver, so please turn over to the next paragraph.


Next Previous Contents