Linuxdoc Linux Questions
Click here to ask our community of linux experts!
Custom Search

4. Getting the user space tools

The Cryptoloop driver requires updated userspace tools to actually create and mount the encrypted file system. An updated util-linux package is needed and can be obtained from http://ftp.cwi.nl/aeb/util-linux/util-linux-2.12.tar.gz. The most current version is 2.12. There will be new versions out soon that will probably introduce major changes, so make sure you check this HOWTO for updates before upgrading to a newer version. Unfortunately there are many patches for util-linux out there. There are differences in the way how encrypted partitions are created and mounted. In order to use util-linux 2.12 with a 2.6 kernel at least the following two patches need to be applied:

  1. Combined losetup patch
  2. Util-linux 2.6 patch

Download the util-linux package and the two patches above. First extract the util-linux package and then apply the two patches:


     tar xvfz util-linux-2.12.tar.gz

     cd util-linux-2.12

     patch -p1 < /path_to_patchfile/losetup-combined.patch

     patch -p1 < /path_to_patchfile/util-linux-2.12-kernel-2.6.patch
     

After applying the patches, compile and install util-linux according to the instructions in the INSTALL file.

I recommend to use Gentoo Linux, which automatically applies these patches when emerging the util-linux patches. Other distributions may have versions of util-linux available, that have these patches aleady applied as well.