Linuxdoc Linux Questions
Click here to ask our community of linux experts!
Custom Search
Next Previous Contents

5. Other

5.1 Knoppix

Yesterday (8/28/2003), I tried to boot with a Knoppix cd (3.2) and found out that the computer froze during the SCSI probes.
I encountered the same problem with a more recent version (3.3).

Here is a quick way to prevent this:

When you get the knoppix prompt, add noscsi and your lang settings and press enter:

boot: knoppix noscsi lang=fr

lang=fr is only to ensure that my language will be used even though I overrode the append line.

5.2 Notes about parallel port networking (PLIP) and floppy bus

I recently found out several important hardware flaws on this mainboard. For example I could not get PLIP to work properly, if anyone has, let me know! I used a grey laplink parallel cable (also known as Null Printer Cable) a friend sold me and followed the PLIP Howto. I could watch activity on the pins using a dos tool, but nothing went through, it even gave a warning:

modprobe plip

tail /var/log/messages

kernel: plip: parport0 has no IRQ. Using IRQ-less mode,which is fairly inefficient!
kernel: NET3 PLIP version 2.4-parport pj.oc.irm@ebiing
kernel: plip0: Parallel port at 0x378, not using IRQ.

Karl said:

"I've found there is only one parallel port mode which actually assigns an IRQ in real life (the bios believes differently) I think its EPP but i could be wrong. I haven't used PLIP before but i thought that this may help a little."

I still get the same warning, let me know if it ever worked.

So I had to go on with floppies, since the box didn't have a cdrom drive, and there, I found out that the 486 had a much faster writing speed, more than 10 seconds of difference writing exactly the same image to the the same floppy...

5.3 Notes about mainboard replacement

Contribution of DR hab. Janusz S. Bien

> My computer returned from the service with the mainboard replaced. In
> principle this is still ECS K7S5A, but seems to have a different sound
> chip.

I have now (with kernel 2.4.27, see below):

Jan 31 10:51:47 galicja kernel: i810: SiS 7012 found at IO 0xd800 and 0xdc0=
0, MEM 0x0000 and 0x0000, IRQ 11
[...]
Jan 31 10:51:47 galicja kernel: ac97_codec: AC97  codec, id: CMI65 (CMedia)

Earlier it was

Nov 23 06:42:36 galicja kernel: i810: SiS 7012 found at IO 0xd800 and 0xdc0=
0, MEM 0x0000 and 0x0000, IRQ 11
[...]
Nov 23 06:42:36 galicja kernel: ac97_codec: AC97 Audio codec, id: ALC38(Unk=
nown)

> The result is that with Knoppix of 2003-11-19-EN I have sound from
> xmms and xine, but there is no sound fom xawtv; actually I hear a kind
> of white noise.
> My HD installation - Woody with the kernel upgraded to 2.4.20 -
> behaves in an opposite way: I have sound from xawtv, but no sound from
> xmms and xine.

I just upgraded the kernel to 2.4.27 and situation is now worse: I
have no sound in xawtv, too.

If you have a similar situation, please have a look at the Alsa drivers.

5.4 Links

Warning: If your board is working fine, then don't fix it. Anyway here are the cool links:

5.5 Sensors.conf for the K7s5a-pro

#Thanks to Art Wagner for this contribution (ten.ysaekaepsh@rengawa)

chip "it87-*" "it8705-*" "it8712-*"

# The values below have been tested on Asus CUSI, CUM motherboards.

# Voltage monitors as advised in the It8705 data sheet

         label in0 "VCore"
         label in1 "Vcc2.5v"
         label in2 "Vcc3.3v"
         label in3 "+5V"
         label in4 "+12V"
         label in5 "-12V"
         label in6 "SB 2.5V"
         label in7 "SB 5V"
         label in8 "V battery"

         # vid not monitored by IT8705F

         ignore  vid
# If 3.3V reads 2X too high (Soyo Dragon, for example),
# comment out following line.
#    compute in2   2*@ , @/2
#
       compute in3 ((6.8/10)+1)*@ ,  @/((6.8/10)+1)
       compute in4 ((30/10) +1)*@  , @/((30/10) +1)
# For this family of chips the negative voltage equation is different from
# the lm78.  The chip uses two external resistor for scaling but one is
# tied to a positive reference voltage.  See ITE8705/12 datasheet (SIS950
# data sheet is wrong)
# Vs = (1 + Rin/Rf) * Vin - (Rin/Rf) * Vref.
# Vref = 4.096 volts, Vin is voltage measured, Vs is actual voltage.

# The next two are negative voltages (-12 and -5).
# The following formulas must be used. Unfortunately the datasheet
# does not give recommendations for Rin, Rf, but we can back into
# them based on a nominal +2V input to the chip, together with a 4.096V
Vref.
# Formula:
#    actual V = (Vmeasured * (1 + Rin/Rf)) - (Vref * (Rin/Rf))
#    For -12V input use Rin/Rf = 6.68
#    For -5V input use Rin/Rf = 3.33
# Then you can convert the forumula to a standard form like:
# compute in5 (7.67 * @) - 27.36  ,  (@ + 27.36) / 7.67
# compute in6 (4.33 * @) - 13.64  ,  (@ + 13.64) / 4.33
#
# this much simpler version is reported to work for a
# Eltite Group K7S5A board
#
      compute in5 -(36/10)*@, -@/(36/10)
#     compute in6 -(56/10)*@, -@/(56/10)
      compute in6 (4.33*@) -13.64 , (@ +13.64) / 4.33
      compute in7 ((6.8/10)+1)*@,  @/((6.8/10)+1)
#
      set in0_min 1.6 * 0.95
      set in0_max 1.6 * 1.05
      set in1_min 2.4
      set in1_max 2.6
      set in2_min 3.3 * 0.95
      set in2_max 3.3 * 1.05
      set in3_min 5.0 * 0.95
      set in3_max 5.0 * 1.05
      set in4_min  12 * 0.95
      set in4_max  12 * 1.05
      set in5_min -12 * 0.95
      set in5_max -12 * 1.05
      set in6_min  2.5 * 0.95
      set in6_max  2.5 * 1.05
      set in7_min   5 * 0.95
      set in7_max   5 * 1.05

#     Temperature
   set in0_min 1.6 * 0.95
   set in0_max 1.6 * 1.05
   set in1_min 2.4
   set in1_max 2.6
   set in2_min 3.3 * 0.95
   set in2_max 3.3 * 1.05
   set in3_min 5.0 * 0.95
   set in3_max 5.0 * 1.05
   set in4_min  12 * 0.95
   set in4_max  12 * 1.05
   set in5_min -12 * 0.95
   set in5_max -12 * 1.05
   set in6_min  2.5 * 0.95
   set in6_max  2.5 * 1.05
   set in7_min   5 * 0.95
   set in7_max   5 * 1.05
                                                                                                                                                
   label temp3       "Processor"
   set   temp3_over  70
   set   temp3_hyst  25
   label temp2       "Mainboard"
   set   temp2_over  70
   set   temp2_hyst  25
   ignore temp1

     # Fans

   label fan1"Processor's Fan"
   set fan1_min 1800
   ignore fan3
   ignore fan2

5.6 Some words (About BIOS)

Alvaro

Using a modified BIOS, I was able to successfully overclock my Athlon 1000Mhz to 1050Mhz flawlessy, but when I messed with hdparm (30Gig Western Digital hard drive) using hdparm -c1 -X66 /dev/hda, I managed to corrupt my filesystem, so beware.

If you are a real tweaker, you might want to change your BIOS Logo and stuff, some people tried that and it worked OK, some others not, so they had to flash their BIOS again (blindly with a bootdisk and a working bios in it) to make the board work again. It is really up to you. Search Google or OC Workbench and you'll be on your way.

Good Luck! :-)

Karl

"Also i recommend you try using either the HoneyX bios or the CHEEPOman bios for the k7s5a instead of the official release, it gives you more control although some problems with non-atapi CD drives (my dvd goes crazy in linux with cheepoman)

The cheepoman bios also fixes several issues which ECS has still not attended to.

These bios roms are unsupported by ECS please bare that in mind, also they are meant for overclocking more than anything else, overclocking in such a way as you don't need a pencil ;)"


Next Previous Contents