Linuxdoc Linux Questions
Click here to ask our community of linux experts!
Custom Search
Custom Search
Custom Search

Chapter 8. Debugging

There are any number of reasons that your connection does not work - chat has failed to complete correctly, you have a dirty line, etc. So check your syslog for indications.

8.1. I have compiled PPP support into the kernel, but...

A very common problem is that people compile PPP support into the kernel and yet when they try to run pppd, the kernel complains that it does not support ppp! There are a variety of reasons this can occur.

8.1.1. Are you booting the right kernel?

Whilst you have recompiled your kernel to support ppp, you are not booting the new kernel. This can happen if you do not update /etc/lilo.conf and rerun lilo.

A good check on the kernel can be obtained by issuing the command uname -a, which should produce a line like:-

Linux archenland 2.0.28 #2 Thu Feb 13 12:31:37 EST 1997 i586

This gives the kernel version and the date on which this kernel was compiled - which should give you a pretty good idea of what is going on.

8.1.2. Did you compile ppp kernel support as a module?

If you compiled your kernel ppp support as a module, but did not make and install the modules, then you can get this error. Check the kernel-HOWTO and the README file in /usr/src/linux!

Another module connected possibility is that you are expecting required modules to be automatically loaded, but are not running the kerneld daemon (which auto-loads and unloads modules on the fly). Check the kerneld mini-HOWTO for information on setting up kerneld.

8.1.3. Are you using the correct version of PPP for your kernel?

You must use ppp-2.2 with kernel version 2.0.x. You can use ppp-2.2 with kernel version 1.2.x (if you patch the kernel), otherwise you must use ppp-2.1.2.

8.1.4. Are you running pppd as root?

If you are not running pppd as the root user (and pppd is not suid to root), you can receive this message.