Linuxdoc Linux Questions
Click here to ask our community of linux experts!
Custom Search

3. What Software and Software Patches Do I Need?

3.1. Linux Kernel

Linux versions 1.2.X requires the IPalias patch alias-patch-1.2.1-v1 and alias-net-tools.tar. I'm not sure if 1.3.X supports this patch yet. For more information on the IPalias patch see ftp://ftp.mindspring.com/users/rsanders/ipalias/

Using multiple dummy interfaces has been suggested in place of the IPalias solution. While the dummy solution may work, it does not appear to be as clean as the IPalias solution. For more information on using Apache and the dummy solution see Aram Mirzadeh's virtual hosting information at http://www.qosina.com/apache/virtual.html

All that is required to add a new alias using the IPalias method is: > /sbin/ifconfig eth0 alias www.domainX.com

Also, the IPalias solution is supported on several other platforms.

3.2. HTTP Servers

NCSA 1.5, Apache, and Spinner support Virtual hosting. http://hoohoo.ncsa.uiuc.edu/docs/Overview.html http://www.apache.org/ http://spinner.infovav.se/