Linuxdoc Linux Questions
Click here to ask our community of linux experts!
Custom Search

3.1. Installing the Backstreet Ruby/ Ruby-2.6 kernel

Now it's time to install the kernel.

The easiest way would be to pull an already prepared binary kernel; there are packages for some distributions (currently only Mandrake and Debian) or a source package, and rebuild it on your system.

If for some reason you cannot use them or have problems using them you can also build your own kernel with the Backstreet Ruby/ Ruby-2.6 patch. For more information how to do this visit the Backstreet Ruby page on building and installing the kernel: http://startx.times.lv (or some of the mirrors) -> Documentation -> Quick Kernel.

(If you are new to Linux, reading "The Linux Kernel HOWTO", http://tldp.org/HOWTO/Kernel-HOWTO.html, could be very helpful.)

You can find binary kernel packages for Mandrake at http://karlovo.demon.co.uk/~svetlio/ruby-contrib/.

Debian binary kernel packages are available at http://www.schuldei.org/debian/bruby, or as apt repository "deb http://www.schuldei.org/debian/bruby ./ "

Note Note
 
  • If you are going to use USB input devices, it's recommended to use the hid driver instead of usbkbd/ usbmouse.

  • Upon loading the hid driver, you might get the following error message:

    [root@svetljo RPM]# modprobe hid
    modprobe: Can't locate module keybdev which is needed for hid
    [root@svetljo RPM]#
    

    The reason is that in some version of the module-utils package this dependency is hardcoded, but overrideable, so you should override it by adding "above hid usbcore" to your /etc/modules.conf