Linuxdoc Linux Questions
Click here to ask our community of linux experts!
Custom Search

Chapter 6. Troubleshooting or PANIC!

If nothing has gone right, let's do some troubleshooting. Use your camera and see if you still have pictures on it. If you do, skip the rest of this paragraph. If you don't, they should be someplace, check again. If not, and you can not find them, go take some more. Turn your camera off and plug it in and boot up again.

Check to see if the mount point unlinked by mv,/mnt/camera is there. If it's gone create it again. Sometimes the mount point disappears in modified mode. Also, I have notice on my system that sometimes the SCSI device in /dev (sda1) gets removed. Check that also and replace if needed.

Clean up all the extra directories you got from the script you ran that produced the errors and run your new script with the directories and see if it works. To make it easier to clean up all the directories and files you may have to su - if you're in user mode. Be sure to change back when you get through. See Appendix C at the end of this document.

Type:


[bash]$ dmesg

and you should see this somewhere:


hub.c: USB new device connect on bus1/1, assigned device number 2
usb.c: USB device 2 (vend/prod 0x54c/0x10) is not claimed by any active driver. (The 
0x54c/0x10 will be different for different vendors.)

If you see this, your USB mass storage device in recognized.

Now turn your camera on and run the script file (the modified one) and you should see something like this when you run dmesg again:


[bash]$ dmesg

SCSI subsystem driver Revision: 1.00
Initializing USB Mass Storage driver...
usb.c: registered new driver usb-storage
scsi0 : SCSI emulation for USB Mass Storage devices
Vendor: Sony Model: Sony DSC Rev: 3.22
Type: Direct-Access ANSI SCSI revision: 02
WARNING: USB Mass Storage data integrity not assured
USB Mass Storage device found at 2
USB Mass Storage support registered.
Attached scsi removable disk sda at scsi0, channel 0, id 0, lun 0
SCSI device sda: 126848 512-byte hdwr sectors (65 MB)
sda: Write Protect is off
/dev/scsi/host0/bus0/target0/lun0: p1
usb-uhci.c: interrupt, status 3, frame# 1628

Now run this command and read Appendix B.


[bash]$ lsmod

If the information from running lsmod appears as in Appendix B,and your dmesg shows the information listed above, and there are no pictures, I don't know what is wrong. Unfortunately, the only thing I know to do is go thru the whole process again. Only this time use the re-direction option >filename to capture the results. Post this to one of these 2 newsgroups:

telling what you've done and ask for help. Include everything you can think of, the more information the better, and e-mail me at the same time. My address is: daveekelly@earthlink.net.